The supported languages are:

PHP 5.2.17 5.3.28 5.4.x 5.5.x modules for: MySQL , gettext, image management jpeg and png, GDlib (Graphic Development) versions 1 and 2, Netpbm, FreeType characters, cryptography with Mcrypt,  xslt-Sablotron. Backward compatibility for global variables (register_global = on), enabled file extensions: php, php3, phtml*

- PERL5.10.x installed modules: DBI, DBD::mysql, DBD::Pg, DBD::CVS, LWP, CGI, Crypt, Digest, Net and others. Enabled extensions: any, they just need to have the right execute permissions

- SSI: are enabled, with limitation on the "exec cmd" directive for security reasons, instead of which you can use
<!--#include virtual="cgi-bin/nomescript" --> Enabled extensions: shtml

- RUBY-1.9.2: modules for mysql and postgresql interface

- PYTHON-2.6.x: modules for mysql and postgresql, to install new ones the same process for perl applies.

- BASH-3.2.x: with common commands: sed, awk, grep, cat, ls, sleep and others.

- C: standard libraries (stdio.h, math.h, zlib.h ) gdbm, mysql, pgsql. (cgi in C must already be compiled and transferred in the server in binary form). If libraries which the user uses are missing, you simply need to statically compile the binary for GNU/Linux with i386 architecture.

NB: We remind you that the perl, python, ruby, sh scripts and any executable files (like .exe or .cgi) must be published in the cgi-bin folder, such executable files do not work unless they are published in this folder.

*Configuration of PHP and its variables can be displayed through the ver.php script created in each domain during the activation process (or through the provided "Test PHP - phpinfo() " tool found in the domain control panel). In order to ensure the services and the servers which are hosting the domains run correctly, some PHP parameters cannot be changed. For more information please open a Support ticket.